Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 04, 2026 - 08:00 CET
Scheduled
The HSMs in our QSCDs (Qualified Signature Creation Device) will be replaced with latest Common Criteria certified version. While the replacement is performed it wouldn't be possible to create signatures, but it is possible to create new sign flows and download already completed signed documents.
Posted Feb 24, 2026 - 10:25 CET
This scheduled maintenance affected: Signing Service.